База знаний
База знаний:
Mikrotik: l2tp vpn site to site (lan to lan) example
Автор [ADMINGROUP] Oleksandr Usov на 28 October 2015 11:07 AM

На сервере

#Создаем пул для впн клиентов (даже если у нас нет DHCP пула на данном микротике - его создавать не нужно)
/ip pool add name=lan_vpn ranges=192.168.182.220-192.168.182.230

#Создаем профайл для l2tp клиентов
/ppp profile add name=l2tp-vpn-lan local-address=192.168.182.100 remote-address=lan_vpn dns-server=192.168.182.100

#Создаем l2tp-server
/interface l2tp-server server set enabled=yes authentication=mschap2 default-profile=l2tp-vpn-lan

#Добавляем пользователя (клиента)
/ppp secret add name=mikrotik password=SjhkjfhuIASGnhbso!2s service=l2tp profile=l2tp-vpn-lan


#Включаем IPsec (на клиенте я ненастраивал его, и пока работает l2tp без него)
/ip ipsec peer add address=0.0.0.0/0 port=500 auth-method=pre-shared-key secret="SjhkjfhuIASGnhbso!2s" exchange-mode=main-l2tp send-initial-contact=yes nat-traversal=yes proposal-check=obey hash-algorithm=sha1 enc-algorithm=3des dh-group=modp1024 lifetime="1d 00:00:00" dpd-interval=120 dpd-maximum-failures=
/ip ipsec proposal set default auth-algorithms=sha1 enc-algorithms=3des,aes-256 lifetime=30m pfs-group=

#Включение Proxy-ARP
#Поскольку компьютеры в локальной сети и удаленные клиенты используют IP адреса из одной и той же подсети, необходимо включить proxy-arp на интерфейсе подключенном к локальной сети.
#В нашем примере этот интерфейс у микротика назван LAN:

/interface ethernet set LAN arp=proxy-arp

 

На клиенте

/interface l2tp-client add name=client_to_l2tp_server connect-to=PUBLIC.IP.OF.L2TP.SERVER user=mikrotik password=SjhkjfhuIASGnhbso!2s allow=mschap2 disabled=no

Также на клиенте и на сервере нужно добавить маршруты в локальную сеть друг друга через IP/интерфейс l2tp-клиента.

 


Комментарии (0)
Добавить новый комментарий
 
 
Полное имя:
Email:
Комментарии: